Can't load National Catholic Register website

Anyone having trouble getting to the National Catholic Register site? (ncregister.com) I keep getting an errors message from OpenDNS guide, stating that nameservers are failing. (???)

I just tried it and it loaded fine.:shrug:

I can access NC Register without problem. I am using Firefox as my browser. I just tried accessing the website with Chrome and had no problem, either.

Jumpfrog, would you be willing to try entering the IP address for NC Register and see if that makes a difference?

Here is their IP address

164.109.56.57

I would consider that a blessing :slight_smile:

:confused:

Perhaps you are confusing the National Catholic Register (which is owned by EWTN) with the National Catholic Reporter.

They have similar names, but very different outlooks. :o

I get the same message with the IP address, in firefox and IE. However, I can get it on my ipod touch. ???

My apologies.

God bless,
Paul

DISCLAIMER: The views and opinions expressed in these forums do not necessarily reflect those of Catholic Answers. For official apologetics resources please visit www.catholic.com.